hdu 1789 Doing Homework again 贪心算法

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    

Memory Limit: 32768/32768 K (Java/Others)

 

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
  Output
For each test case, you should output the smallest total reduced score, one line per test case.
 
Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 
Sample Output
  
  
0 3 5
 
问题描述Ignatius比赛回来之后,每位老师给Ignatius一个交作业的最后期限,如果交不上去就扣分。每门作业都要一天时间完成,求最少扣多少分。先输入一个T表示有T组测试数据,接下来每组数据先输入一个N,代表有N个作业,然后输入两行,第一行表示每门作业要交的日期,第二行表示对应的如果不交这门作业要扣的分数。输出要扣的最少分数。
解题思路:先对日期从小到大排序,如果日期相同,则扣分多的排在前面。如果相同日期内有扣分多的,则就用前面做扣分少的作业的时间来做这门作业;如果没有比他小的,就扣这门作业的分。
 
AC代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct work{
    int sco;
    int time;
    bool flag; //flag为1表示可以完成
}a[1005];

bool comp(work a1, work a2) {
    if(a1.time != a2.time)
        return a1.time < a2.time;
    return a1.sco > a2.sco;
}

int main() {
    int T, n, i, j;
    scanf("%d",&T);
    while(T--) {
        scanf("%d",&n);
        for(i = 0; i < n; i++)
            scanf("%d",&a[i].time);
        for(i = 0; i < n; i++) {
            scanf("%d",&a[i].sco);
            a[i].flag = true;
        }
        sort(a, a+n, comp);
        int sum = 0, k = 1;
        for(i = 0; i < n; i++) {
            if(a[i].time >= k) { //如果要完成的作业的日在当前日期之后,则可以完成该作业  
                k++;
                continue;
            }
            int p = a[i].sco, pos = i;
            for(j = 0; j < i; j++)
                if(a[j].sco < p && a[j].flag) {
                    p = a[j].sco;
                    pos = j;
                }
            sum += p;
            a[pos].flag = false;
        }
        printf("%d\n",sum);
    }
    return 0;
}
 
  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值